一个热爱网络的小学教师

为网站添加IE6升级提示(来自NeoEase)

最近很杯具,我找了N多主题,发现支持IE6的很少,不过为了用户考虑,还是要继续跟万恶的IE6死磕,呵呵。关于wordpress主题与IE6的兼容性问题,前面我已经发布过几篇文章了:为网站添加IE6升级提示(JavaScript+jQuery两种方法)解决WordPress主题不兼容IE6又一法:使用IE6专用主题,第一种方法是为网站添加IE6升级提示,但是无法保证显示效果,该错位的还是错位,而且需要修改一些代码,我这样的半瓶醋水平感觉鸭梨很大啊。第二种方法需要借助插件IE-Theme启用IE专用的主题,当检测到用户的IE版本为设置值后,自动为用户启用专用主题,这个方法虽然避免了错位带来的用户体验不佳的问题,但是更加无法保证显示效果,因为不同的主题展示的内容也不同,而且我对这种方法的搜索引擎友好度也有些不放心问了几个网友,也没人给个确切答案。

看来要彻底解决这个问题,只有尽量保证IE6、IE7、IE8等的兼容了。

今天再分享一个更加简单的为网站添加IE6升级提示的方法:

将下面的代码复制到wordpress主题合适的地方,比如footer.php(总之保证在“/html”标记之前就行)。


(说明,如果您直接复制此段代码使用,一定不要忘了把引号改过来,顺便求大家推荐一款好用的代码高亮插件。)

当IE6的用户访问我们的网站的时候,页面右下角会弹出提示,提示用户升级到IE8或其他浏览器,这种方法比起我之前采取的第一种方法来,更加简单,只需要几行代码即可搞定,实在是小白的福音,感谢NeoEase,感谢他的“Let’s kill IE6”计划

另外,由于IE7也存在一定程度的兼容性不佳问题,我们也可以顺便对IE7的用户做个提示。

具体方法:

下载http://letskillie6.googlecode.com/svn/trunk/2/zh_CN.js这个js文件到本地,修改其中的代码,然后在footer.php多加一句对于IE7浏览器的判断即可,在这里我只是提供一个思路,具体的修改方法大家看着办就行,不要问我,我也只是小白而已,呵呵。

赞(0) 打赏
转载请标明出处:高海鹏老师的博客 » 为网站添加IE6升级提示(来自NeoEase)
分享到: 更多 (0)

留言 2

Protected by WP Anti Spam
  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
  1. #0

    为什么就这一篇文章里面有提示,不是全站的效果?

    高亮的插件,之前有看到几个博主在用 SyntaxHighlighter 你试试看,另外想换个友链

    不知道行不行!

    qianiqan9年前 (2013-01-18)回复
    • SyntaxHighlighter使用太复杂,我已经换成玻璃泉的代码高亮插件了。

      高海鹏9年前 (2013-01-19)回复

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏